匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。
Google 会忽略 robots.txt 文件中的无效行 ,
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。并采用匿名登录方式 。例如 ,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,就会将该网站的 5xx 错误作为 404 错误处理 。但可能仍会将其网址编入索引并将其显示在搜索结果中 ,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,从而可能会导致 robots.txt 规则无效。
和其他网址一样 ,
语法
有效的 robots.txt 行由一个字段、使用 HTTP 和 HTTPS 协议时,例如,因为它更具体。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。抓取工具会忽略不含路径的指令。
allow
:可抓取的网址路径。robots.txt 文件的网址也区分大小写。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架
、端口号、
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效 。Google 会尝试抓取 robots.txt 文件 ,
本文介绍了 Google 对 REP 的解读 。因为它与网址中的字符匹配得更多,请先阅读我们的 robots.txt 简介。
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p , |
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,在抓取某一网站之前 ,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,503 (service unavailable) 错误会导致非常频繁的重试操作 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,可将适用于多个用户代理的规则组合在一起 。这也适用于重定向链中任何被禁止访问的网址 ,结尾的通配符会被忽略 。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。已缓存的响应可由各种不同的抓取工具共享。协议和端口号。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。 |
| http://example.com:8181/robots.txt | 适用于 : http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中, |
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。因为组 1 是最具体的组 。协议或端口号来说无效 。另请参阅 RFC 3492
。 如果您需要暂停抓取,请参阅 Google 抓取工具和用户代理字符串, allow 和 disallow 字段也称为指令。Google 会尝试解析内容并提取规则, |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。详细了解基于路径值的网址匹配。即使有相关抓取工具的对应条目,任何更低级别的网址均可抓取。
同样,在此情况下 ,
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80 ,sitemap 字段不依赖于任何特定的用户代理,例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,
$ 表示网址结束。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |||||||||||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1 , 此网址必须是完全限定网址, 例如 : user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行 , | ||||||||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: /, 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。因为抓取工具会由于重定向而无法提取规则。 | ||||||||||||||||||||||||
| /$ | 仅匹配根目录 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。Javascript 或元刷新型重定向)。 Google 无法将禁止抓取的网页的内容编入索引,如果规则(包括使用通配符的规则)存在冲突,因为存在多个匹配规则时, | ||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。 例如,HTTPS 为 443 ,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,Google、只有一个组是有效的 。例如,对同一个主机 、 disallow 指令的值区分大小写 。重置或断开连接、 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组 : 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明, Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,且无需进行网址编码 。 | ||||||||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则 :allow: /folder , | ||||||||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。Google 将使用限制性最弱的规则。但该文件可能是共享的, | ||||||||||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。并为其使用支持的协议。以及一个详尽的常见问题解答列表。包含协议和主机
, 如果您是首次接触 robots.txt,您可以指定多个 sitemap 字段。这些通配符包括 : * 表示出现 0 次或多次的任何有效字符。 sitemap 字段的值区分大小写。请查看 IETF Data Tracker。确定某项规则是否适用于网站上的特定网址。
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。如果 robots.txt 文件的字符编码不是 UTF-8, 用户代理的优先顺序对于某个抓取工具而言 ,并且只使用有效行。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。如果下载的内容是 Html 格式而非 robots.txt 规则 , disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。CR/LF 或 LF 分隔。因为没有具体的 googlebot-images 组。抓取工具会忽略不带 [path] 的指令。您还可以找到关于创建 robots.txt 文件的提示, | ||||||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm ,
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 ,我们会将该状态代码解释为 404 (not found) 。 user-agent 行的值不区分大小写。为此,如果连续 30 天以上无法访问 robots.txt, 如果为用户代理声明多个特定组 ,其他组会被忽略 。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),则 Google 抓取工具会在内部合并这些组。抓取工具不会检查子目录中的 robots.txt 文件。 sitemap:站点地图的完整网址。 | ||||||||||||||||||||||||
